(0day) IBM Lotus Domino iCalendar Meeting Request Parsing Remote Code Execution Vulnerability

2011-02-07T00:00:00
ID ZDI-11-048
Type zdi
Reporter Anonymous
Modified 2011-11-09T00:00:00

Description

This vulnerability allows remote attackers to execute arbitrary code on systems with vulnerable installations of IBM Lotus Domino. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the nrouter.exe service while processing a malformed calendar meeting request. The process copies the contents of the name parameter within the Content-Type header into a fixed size stack buffer. By providing enough data this buffer can overflow leading to arbitrary code execution under the context of the SYSTEM user.