Symantec Endpoint Protection Manager Reporting Server fw_charts.php Remote Code Execution Vulnerability

2010-12-15T00:00:00
ID ZDI-10-291
Type zdi
Reporter Andrea Micalizzi aka rgod
Modified 2010-11-09T00:00:00

Description

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Symantec Endpoint Protection. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the portion of the server that generates reports. Due to the combination of insufficient checks being performed on the application and failure to authenticate a user for generating a chart, an attacker can overwrite arbitrary files on a server. Careful exploitation can lead to code execution under the context of the php interpreter.