Microsoft Internet Explorer Stylesheet Array Removal Remote Code Execution Vulnerability

2010-06-08T00:00:00
ID ZDI-10-102
Type zdi
Reporter Peter Vreugdenhil (http://twitter.com/WTFuzz)
Modified 2010-06-22T00:00:00

Description

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Microsoft Internet Explorer. User interaction is required in that a target must visit a malicious page. The specific flaw exists within IE's support for the CStyleSheet object. When a style sheet array is created it contains a reference to it's root container. If the stylesheet was created as part of an element not in a markup the root container can be freed when that element is destroyed. When the application attempts to use the stylesheet after this, an invalid pointer is utilized. This can be leveraged by attackers to execute arbitrary code under the context of the user running the browser.