Novell NetStorage xsrvd Long Pathname Remote Code Execution Vulnerability

2010-02-23T00:00:00
ID ZDI-10-021
Type zdi
Reporter 1c239c43f521145fa8385d64a9c32243
Modified 2010-11-09T00:00:00

Description

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Novell NetStorage. Authentication is not required to exploit this vulnerability.

The specific flaws exists within the xsrvd process during the wide character conversion of requested file paths. In conjunction with a long username value the file path conversion will result in a heap overflow corrupting a chunk that will be immediately freed. This can be leveraged by remote attackers to compromise the NetStorage server.