Trillian AIM Plugin Malformed XML Tag Heap Overflow Vulnerability

2008-12-04T00:00:00
ID ZDI-08-079
Type zdi
Reporter Damian Put
Modified 2008-06-22T00:00:00

Description

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Cerulean Studios Trillian. Authentication is not required to exploit this vulnerability. The specific flaw exists within the XML processing code for Trillian. When parsing a malformed XML tag, the application does not allocate enough space for it's contents. During copying of this to the newly allocated buffer, the application will overwrite heap structures with attacker-supplied data that can then be leveraged to achieve code execution with the privileges of the application.