Novell eDirectory for Linux LDAP delRequest Stack Overflow Vulnerability

2008-03-26T00:00:00
ID ZDI-08-013
Type zdi
Reporter Anonymous
Modified 2008-11-09T00:00:00

Description

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Novell eDirectory for Linux. Authentication is not required to exploit this vulnerability.

The specific flaw exists in the libnldap library. When a large LDAP delRequest message is sent, a stack overflow occurs overwriting a function pointer. This results in a situation allowing the execution of arbitrary code.