Citrix Metaframe Presentation Server IMA Service Heap Overflow Vulnerability

2008-01-17T00:00:00
ID ZDI-08-002
Type zdi
Reporter Eric DETOISIEN
Modified 2008-11-09T00:00:00

Description

This vulnerability allows attackers to execute arbitrary code on vulnerable installations of Citrix Presentation Server. Authentication is not required to exploit this vulnerability.

The specific flaw resides in the Independent Management Architecture service, ImaSrv.exe, which listens by default on TCP port 2512 or 2513. The process trusts a user-suppled value as a parameter to a memory allocation. By supplying a specific value, an undersized heap buffer may be allocated. Subsequently, an attacker can then overflow that heap buffer by sending an overly large packet leading to arbitrary code execution in the context of the SYSTEM user.