Novell Client NWSPOOL.DLL Stack Overflow Vulnerability

2007-08-06T00:00:00
ID ZDI-07-045
Type zdi
Reporter Anonymous
Modified 2007-11-09T00:00:00

Description

This vulnerability allows remote attackers to execute arbitrary code on systems with vulnerable installations of the Novell Netware Client. Authentication is not required to exploit this vulnerability.

The specific flaw exists in nwspool.dll which is responsible for handling RPC requests through the spoolss named pipe. Several RPC functions exposed by this DLL do not properly verify argument sizes and subsequently copy user-supplied data to a stack-based buffer resulting in an exploitable overflow.