Panda Software AdminSecure Agent Heap Overflow Vulnerability

2007-07-20T00:00:00
ID ZDI-07-041
Type zdi
Reporter Tenable Network Security
Modified 2007-11-09T00:00:00

Description

This vulnerability allows remote attackers to execute arbitrary code on affected installations of Panda AdminSecure. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the AdminSecure agent which binds by default to TCP port 19226 or 19227. When processing traffic on the listening port, the agent trusts a user-supplied length value for a memory allocation. Specific size values can result in an integer overflow and subsequently insufficient allocation size. This results in a heap-based buffer overflow that can be leverage to execute arbitrary code.