Unfixed XSS vulnerability at www.foursquare.org

2009-01-27T00:00:00
ID XSSED:57457
Type xssed
Reporter g4ng-sT0r
Modified 2010-06-07T00:00:00

Description

Security researcher g4ng-sT0r, has submitted on 27/01/2009 a cross-site-scripting (XSS) vulnerability affecting www.foursquare.org, which at the time of submission ranked 351338 on the web according to Alexa.
We manually validated and published a mirror of this vulnerability on 06/07/2010. It is currently unfixed.
If you believe that this security issue has been corrected, please send us an e-mail.

Vulnerable URL: http://www.foursquare.org/search/results.sd?keyword=%22%3E%3Cscript%3Ealert(%22down+with+religion!+~g4ng-sT0r~%22)%3C%2Fscript%3E&keyword.x=0&keyword.y=0