x86: PV guest may crash Xen with XPTI

2018-04-25T12:00:00
ID XSA-259
Type xen
Reporter Xen Project
Modified 2018-04-25T12:03:00

Description

ISSUE DESCRIPTION

The workaround for the Meltdown vulnerability (XSA-254) failed to deal with an error code path connecting the INT 80 handling with general exception handling. This results in an unconditional write attempt of the value zero to an address near 2^64, in cases where a PV guest has no handler installed for INT 80 on one of its vCPU-s.

IMPACT

A malicious or buggy guest may cause a hypervisor crash, resulting in a Denial of Service (DoS) affecting the entire host.

VULNERABLE SYSTEMS

All Xen versions which the XSA-254 fixes were applied to are vulnerable. Only x86 systems are vulnerable. ARM systems are not vulnerable. Only x86 PV guests can exploit the vulnerability. x86 PVH and HVM guests cannot exploit the vulnerability.