Lucene search

K
wpvulndbPablo SanchezWPVDB-ID:E4804850-2AC2-4CEC-BC27-07ED191D96DA
HistoryAug 30, 2023 - 12:00 a.m.

Translate WordPress with GTranslate < 3.0.4 - Admin+ Stored XSS

2023-08-3000:00:00
Pablo Sanchez
wpscan.com
9
wordpress
gtranslate
vulnerability
stored xss
admin
settings
configuration
intercept
save request
unfiltered_html
multisite
parameters

4.8 Medium

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

HIGH

User Interaction

REQUIRED

Scope

CHANGED

Confidentiality Impact

LOW

Integrity Impact

LOW

Availability Impact

NONE

CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

5.8 Medium

AI Score

Confidence

High

4.3 Medium

CVSS2

Access Vector

NETWORK

Access Complexity

MEDIUM

Authentication

MULTIPLE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

NONE

AV:N/AC:M/Au:M/C:P/I:P/A:N

0.0004 Low

EPSS

Percentile

14.1%

Description The plugin does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup). This vulnerability affects multiple parameters.

PoC

1. Go to β€œSettings > Gtranslate” 2. Make changes to the configuration and intercept the save request 3. Replace in value of incl_langs%5B%5D to `alert(1)

CPENameOperatorVersion
eq3.0.4

4.8 Medium

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

HIGH

User Interaction

REQUIRED

Scope

CHANGED

Confidentiality Impact

LOW

Integrity Impact

LOW

Availability Impact

NONE

CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

5.8 Medium

AI Score

Confidence

High

4.3 Medium

CVSS2

Access Vector

NETWORK

Access Complexity

MEDIUM

Authentication

MULTIPLE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

NONE

AV:N/AC:M/Au:M/C:P/I:P/A:N

0.0004 Low

EPSS

Percentile

14.1%

Related for WPVDB-ID:E4804850-2AC2-4CEC-BC27-07ED191D96DA