logo
DATABASE RESOURCES PRICING ABOUT US

GenerateBlocks < 1.4.0 - Contributor+ Stored Cross-Site Scripting

Description

The plugin does not validate the generateblocks/container block's tagName attribute, which could allow users with a role as low as contributor to perform Cross-Site Scripting attacks. ### PoC Add the following code in a post/page while in code editor mode with an Contributor account: Then view/preview the page/post to trigger the XSS


Affected Software


CPE Name Name Version
generateblocks 1.4.0

Related