VMware vCenter Server updates address a LDAP certificate validation issue

2015-09-16T00:00:00
ID VMSA-2015-0006
Type vmware
Reporter VMware
Modified 2015-10-01T00:00:00

Description

VMware vCenter Server LDAP certificate validation vulnerability.

VMware vCenter Server does not validate the certificate when connecting to a single sign on identity source using LDAPS (LDAP over SSL). This applies when connecting to Active Directory as an LDAP Server or OpenLDAP. Exploitation of this vulnerability may allow an attacker that is able to intercept traffic between vCenter Server and the LDAP server to capture sensitive information. Active Directory (Integrated Windows Authentication) is unaffected.

The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the identifier CVE-2015-6932 to this issue.

Column 4 of the following table lists the action required to remediate the vulnerability in each release, if a solution is available.