Lucene search

K
veracodeVeracode Vulnerability DatabaseVERACODE:46138
HistoryApr 01, 2024 - 10:25 p.m.

Buffer Overflow

2024-04-0122:25:23
Veracode Vulnerability Database
sca.analysiscenter.veracode.com
3
gtkwave
vulnerability
bounds checking
fstfread
arbitrary code
malicious file
software

CVSS3

7.8

Attack Vector

LOCAL

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

AI Score

7.5

Confidence

Low

EPSS

0.001

Percentile

23.9%

gtkwave is vulnerable to Buffer Overflow. The vulnerability is due to inadequate bounds checking in the fstFread copy function. This allows an attacker to execute arbitrary code by providing a maliciously crafted .fst file.

CVSS3

7.8

Attack Vector

LOCAL

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

AI Score

7.5

Confidence

Low

EPSS

0.001

Percentile

23.9%