Lucene search

K
veracodeVeracode Vulnerability DatabaseVERACODE:42923
HistoryAug 23, 2023 - 5:16 p.m.

Remote Code Execution (RCE)

2023-08-2317:16:56
Veracode Vulnerability Database
sca.analysiscenter.veracode.com
146
remote code execution
vulnerability
mosquitto
library
arbitrary code
remote attacker

CVSS3

5.8

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

CHANGED

Confidentiality Impact

NONE

Integrity Impact

NONE

Availability Impact

LOW

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:L

EPSS

0

Percentile

13.2%

mosquitto is vulnerable to a remote code execution vulnerability. This vulnerability exists due to a flaw in the way the library handles certain requests. A remote attacker can exploit this vulnerability to execute arbitrary code on the affected system.

CVSS3

5.8

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

CHANGED

Confidentiality Impact

NONE

Integrity Impact

NONE

Availability Impact

LOW

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:L

EPSS

0

Percentile

13.2%