logo
DATABASE RESOURCES PRICING ABOUT US

HTTP Request Smuggling (HRS)

Description

twisted is vulnerable to http request smuggling. The vulnerability exists in `twisted.web` due to inconsistent interpretation of http requests which allows a remote attacker to conduct HTTP request smuggling attacks via a crafted request.


Affected Software


CPE Name Name Version
twisted 22.2.0
twisted 16.5.0rc1
twisted 16.4.1
twisted 8.0.0
python-twisted-web 12.1.0__7.el7_8
python-twisted-web 12.1.0__7.el7_8
python-twisted-web 12.1.0__4.el7
python-twisted-web 12.1.0__4.el7
python-twisted-web 12.1.0__6.el7
python-twisted-web 12.1.0__6.el7
python-twisted-web 12.1.0__5.el7_2
python-twisted-web 12.1.0__5.el7_2
python-twisted 16.4.1__19.el8ost
python-twisted 16.4.1__19.el8ost
python-twisted 16.4.1__17.el8ost.1
python-twisted 16.4.1__17.el8ost.1
python-twisted 16.4.1__13.el8stf
python-twisted 16.4.1__13.el8stf
python-twisted 8.2.0__3.1.el6
python-twisted 8.2.0__3.1.el6
python-twisted 16.4.1__12.el8ost
python-twisted 16.4.1__12.el8ost
twisted 22.2.0
twisted 16.5.0rc1
twisted 16.4.1
twisted 8.0.0
python-twisted-web 12.1.0__7.el7_8
python-twisted-web 12.1.0__7.el7_8
python-twisted-web 12.1.0__4.el7
python-twisted-web 12.1.0__4.el7
python-twisted-web 12.1.0__6.el7
python-twisted-web 12.1.0__6.el7
python-twisted-web 12.1.0__5.el7_2
python-twisted-web 12.1.0__5.el7_2
python-twisted 16.4.1__19.el8ost
python-twisted 16.4.1__19.el8ost
python-twisted 16.4.1__17.el8ost.1
python-twisted 16.4.1__17.el8ost.1
python-twisted 16.4.1__13.el8stf
python-twisted 16.4.1__13.el8stf
python-twisted 8.2.0__3.1.el6
python-twisted 8.2.0__3.1.el6
python-twisted 16.4.1__12.el8ost
python-twisted 16.4.1__12.el8ost

Related