logo
DATABASE RESOURCES PRICING ABOUT US

Denial Of Service (DoS)

Description

lz4 is vulnerable to denial of service. An integer overflow occurs when one of the `memmove` arguments is set to negative, resulting in an application crash.


Affected Software


CPE Name Name Version
lz4:sid 1.9.2-2
lz4:bullseye 1.9.2-2
lz4:hirsute 1.9.3-0ubuntu1
lz4:hirsute 1.9.3-1build1
lz4:hirsute 1.9.2-2
lz4 1.8.1.2__4.el8
lz4 1.8.3__2.el8
lz4:3.12 1.9.2-r0
lz4:3.15 1.9.3-r0
lz4:3.14 1.9.3-r0
lz4:3.13 1.9.2-r0
lz4:edge 1.9.3-r0
lz4:edge 1.9.2-r0
lz4:sid 1.9.2-2
lz4:bullseye 1.9.2-2
lz4:hirsute 1.9.3-0ubuntu1
lz4:hirsute 1.9.3-1build1
lz4:hirsute 1.9.2-2
lz4 1.8.1.2__4.el8
lz4 1.8.3__1.el7
lz4 1.7.3__1.el7
lz4 r131__3.el7ost
lz4 1.7.5__3.el7
lz4 1.8.3__2.el8
lz4 r131__2.el7ost
lz4 r131__2.el7
lz4:3.12 1.9.2-r0
lz4:3.15 1.9.3-r0
lz4:3.14 1.9.3-r0
lz4:3.13 1.9.2-r0
lz4:edge 1.9.3-r0
lz4:edge 1.9.2-r0

Related