Lucene search

K
ubuntucveUbuntu.comUB:CVE-2022-34480
HistoryJul 05, 2022 - 12:00 a.m.

CVE-2022-34480

2022-07-0500:00:00
ubuntu.com
ubuntu.com
74
firefox
vulnerability
lg_init()
uninitialized pointer
allocation
ubuntu 22.04
snap

CVSS3

8.8

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

EPSS

0.002

Percentile

56.1%

Within the <code>lg_init()</code> function, if several allocations succeed
but then one fails, an uninitialized pointer would have been freed despite
never being allocated. This vulnerability affects Firefox < 102.

Bugs

Notes

Author Note
mdeslaur starting with Ubuntu 22.04, the firefox package is just a script that installs the Firefox snap
OSVersionArchitecturePackageVersionFilename
ubuntu18.04noarchfirefox< 102.0+build2-0ubuntu0.18.04.1UNKNOWN
ubuntu20.04noarchfirefox< 102.0+build2-0ubuntu0.20.04.1UNKNOWN
ubuntu21.10noarchfirefox< 102.0+build2-0ubuntu0.21.10.1UNKNOWN
ubuntu18.04noarchnss< 2:3.35-2ubuntu2.15UNKNOWN
ubuntu20.04noarchnss< 2:3.49.1-1ubuntu1.8UNKNOWN
ubuntu21.10noarchnss< 2:3.68-1ubuntu1.2UNKNOWN
ubuntu22.04noarchnss< 2:3.68.2-0ubuntu1.1UNKNOWN
ubuntu14.04noarchnss< 2:3.28.4-0ubuntu0.14.04.5+esm11UNKNOWN
ubuntu16.04noarchnss< 2:3.28.4-0ubuntu0.16.04.14+esm3UNKNOWN
ubuntu20.04noarchthunderbird< 1:102.2.2+build1-0ubuntu0.20.04.1UNKNOWN
Rows per page:
1-10 of 111

CVSS3

8.8

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

EPSS

0.002

Percentile

56.1%