logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2022-2938

Description

A flaw was found in the Linux kernel's implementation of Pressure Stall Information. While the feature is disabled by default, it could allow an attacker to crash the system or have other memory-corruption side effects. #### Notes Author| Note ---|--- [sbeattie](<https://launchpad.net/~sbeattie>) | on s390x/focal and newer, CONFIG_PSI_DEFAULT_DISABLED is set (see LP: #1876044), so requires a boot command line argument; other arches have it enabled.


Affected Package


OS OS Version Package Name Package Version
ubuntu 20.04 linux 5.4.0-109.123
ubuntu upstream linux 5.17~rc2
ubuntu upstream linux-aws 5.17~rc2
ubuntu upstream linux-aws-5.0 5.17~rc2
ubuntu upstream linux-aws-5.15 5.17~rc2
ubuntu upstream linux-aws-5.4 5.17~rc2
ubuntu upstream linux-aws-hwe 5.17~rc2
ubuntu upstream linux-azure 5.17~rc2
ubuntu upstream linux-azure-4.15 5.17~rc2
ubuntu upstream linux-azure-5.15 5.17~rc2
ubuntu upstream linux-azure-5.4 5.17~rc2
ubuntu upstream linux-azure-edge 5.17~rc2
ubuntu 20.04 linux-azure-fde any
ubuntu upstream linux-azure-fde 5.17~rc2
ubuntu upstream linux-azure-fde-5.15 any
ubuntu upstream linux-bluefield 5.17~rc2
ubuntu upstream linux-dell300x 5.17~rc2
ubuntu upstream linux-fips 5.17~rc2
ubuntu upstream linux-gcp 5.17~rc2
ubuntu upstream linux-gcp-4.15 5.17~rc2
ubuntu upstream linux-gcp-5.15 5.17~rc2
ubuntu upstream linux-gcp-5.4 5.17~rc2
ubuntu upstream linux-gke 5.17~rc2
ubuntu upstream linux-gke-4.15 5.17~rc2
ubuntu upstream linux-gke-5.0 5.17~rc2
ubuntu upstream linux-gke-5.15 5.17~rc2
ubuntu upstream linux-gke-5.4 5.17~rc2
ubuntu upstream linux-gkeop 5.17~rc2
ubuntu upstream linux-gkeop-5.4 5.17~rc2
ubuntu upstream linux-hwe 5.17~rc2
ubuntu upstream linux-hwe-5.15 5.17~rc2
ubuntu upstream linux-hwe-5.4 5.17~rc2
ubuntu upstream linux-hwe-edge 5.17~rc2
ubuntu upstream linux-ibm 5.17~rc2
ubuntu upstream linux-ibm-5.4 5.17~rc2
ubuntu 20.04 linux-intel-5.13 any
ubuntu upstream linux-intel-5.13 5.17~rc2
ubuntu upstream linux-intel-iotg 5.17~rc2
ubuntu upstream linux-intel-iotg-5.15 5.17~rc2
ubuntu upstream linux-kvm 5.17~rc2
ubuntu upstream linux-lowlatency 5.17~rc2
ubuntu upstream linux-lowlatency-hwe-5.15 5.17~rc2
ubuntu upstream linux-lts-xenial 5.17~rc2
ubuntu upstream linux-oem 5.17~rc2
ubuntu 20.04 linux-oem-5.10 any
ubuntu upstream linux-oem-5.10 5.17~rc2
ubuntu upstream linux-oem-5.14 5.17~rc2
ubuntu upstream linux-oem-5.17 any
ubuntu upstream linux-oem-5.17 5.17~rc2
ubuntu 20.04 linux-oem-5.6 any
ubuntu upstream linux-oem-5.6 5.17~rc2
ubuntu 22.04 linux-oem-6.0 any
ubuntu upstream linux-oem-6.0 any
ubuntu upstream linux-oem-6.1 any
ubuntu upstream linux-oem-osp1 5.17~rc2
ubuntu upstream linux-oracle 5.17~rc2
ubuntu upstream linux-oracle-5.0 5.17~rc2
ubuntu 20.04 linux-oracle-5.13 any
ubuntu upstream linux-oracle-5.13 5.17~rc2
ubuntu upstream linux-oracle-5.15 any
ubuntu upstream linux-oracle-5.4 5.17~rc2
ubuntu upstream linux-raspi 5.17~rc2
ubuntu upstream linux-raspi-5.4 5.17~rc2
ubuntu upstream linux-raspi2 5.17~rc2
ubuntu upstream linux-riscv 5.17~rc2
ubuntu upstream linux-snapdragon 5.17~rc2

Related