logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2022-2318

Description

There are use-after-free vulnerabilities caused by timer handler in net/rose/rose_timer.c of linux that allow attackers to crash linux kernel without any privileges.


Affected Package


OS OS Version Package Name Package Version
ubuntu 22.04 linux 5.15.0-48.54
ubuntu 14.04 linux any
ubuntu upstream linux 5.19~rc5
ubuntu 16.04 linux any
ubuntu 20.04 linux-aws any
ubuntu 22.04 linux-aws 5.15.0-1020.24
ubuntu 14.04 linux-aws any
ubuntu upstream linux-aws 5.19~rc5
ubuntu 16.04 linux-aws any
ubuntu upstream linux-aws-5.0 5.19~rc5
ubuntu 20.04 linux-aws-5.11 any
ubuntu upstream linux-aws-5.11 5.19~rc5
ubuntu 20.04 linux-aws-5.13 any
ubuntu upstream linux-aws-5.13 5.19~rc5
ubuntu 20.04 linux-aws-5.15 5.15.0-1020.24~20.04.1
ubuntu upstream linux-aws-5.15 5.19~rc5
ubuntu upstream linux-aws-5.3 5.19~rc5
ubuntu upstream linux-aws-5.4 5.19~rc5
ubuntu upstream linux-aws-5.8 5.19~rc5
ubuntu upstream linux-aws-hwe 5.19~rc5
ubuntu 16.04 linux-aws-hwe any
ubuntu 20.04 linux-azure any
ubuntu 22.04 linux-azure 5.15.0-1020.25
ubuntu 14.04 linux-azure any
ubuntu upstream linux-azure 5.19~rc5
ubuntu 16.04 linux-azure any
ubuntu upstream linux-azure-4.15 5.19~rc5
ubuntu 20.04 linux-azure-5.11 any
ubuntu upstream linux-azure-5.11 5.19~rc5
ubuntu 20.04 linux-azure-5.13 any
ubuntu upstream linux-azure-5.13 5.19~rc5
ubuntu 20.04 linux-azure-5.15 5.15.0-1020.25~20.04.1
ubuntu upstream linux-azure-5.15 5.19~rc5
ubuntu upstream linux-azure-5.3 5.19~rc5
ubuntu upstream linux-azure-5.4 5.19~rc5
ubuntu upstream linux-azure-5.8 5.19~rc5
ubuntu upstream linux-azure-edge 5.19~rc5
ubuntu 20.04 linux-azure-fde any
ubuntu upstream linux-azure-fde 5.19~rc5
ubuntu 20.04 linux-bluefield any
ubuntu upstream linux-bluefield 5.19~rc5
ubuntu upstream linux-dell300x 5.19~rc5
ubuntu upstream linux-fips 5.19~rc5
ubuntu 16.04 linux-fips any
ubuntu 20.04 linux-gcp any
ubuntu 22.04 linux-gcp 5.15.0-1018.24
ubuntu upstream linux-gcp 5.19~rc5
ubuntu 16.04 linux-gcp any
ubuntu upstream linux-gcp-4.15 5.19~rc5
ubuntu 20.04 linux-gcp-5.11 any
ubuntu upstream linux-gcp-5.11 5.19~rc5
ubuntu 20.04 linux-gcp-5.13 any
ubuntu upstream linux-gcp-5.13 5.19~rc5
ubuntu upstream linux-gcp-5.15 5.19~rc5
ubuntu upstream linux-gcp-5.3 5.19~rc5
ubuntu upstream linux-gcp-5.4 5.19~rc5
ubuntu upstream linux-gcp-5.8 5.19~rc5
ubuntu 20.04 linux-gke any
ubuntu 22.04 linux-gke 5.15.0-1016.19
ubuntu upstream linux-gke 5.19~rc5
ubuntu upstream linux-gke-4.15 5.19~rc5
ubuntu upstream linux-gke-5.0 5.19~rc5
ubuntu upstream linux-gke-5.15 5.19~rc5
ubuntu upstream linux-gke-5.3 5.19~rc5
ubuntu upstream linux-gke-5.4 5.19~rc5
ubuntu 20.04 linux-gkeop any
ubuntu 22.04 linux-gkeop 5.15.0-1003.5
ubuntu upstream linux-gkeop 5.19~rc5
ubuntu upstream linux-gkeop-5.4 5.19~rc5
ubuntu upstream linux-hwe 5.19~rc5
ubuntu 16.04 linux-hwe any
ubuntu upstream linux-hwe-5.11 5.19~rc5
ubuntu 20.04 linux-hwe-5.13 any
ubuntu upstream linux-hwe-5.13 5.19~rc5
ubuntu 20.04 linux-hwe-5.15 5.15.0-48.54~20.04.1
ubuntu upstream linux-hwe-5.15 5.19~rc5
ubuntu upstream linux-hwe-5.4 5.19~rc5
ubuntu upstream linux-hwe-5.8 5.19~rc5
ubuntu upstream linux-hwe-edge 5.19~rc5
ubuntu 20.04 linux-ibm any
ubuntu 22.04 linux-ibm any
ubuntu upstream linux-ibm 5.19~rc5
ubuntu upstream linux-ibm-5.4 5.19~rc5
ubuntu 20.04 linux-intel-5.13 any
ubuntu upstream linux-intel-5.13 5.19~rc5
ubuntu upstream linux-intel-iotg 5.19~rc5
ubuntu upstream linux-intel-iotg-5.15 5.19~rc5
ubuntu 20.04 linux-kvm any
ubuntu 22.04 linux-kvm 5.15.0-1018.22
ubuntu upstream linux-kvm 5.19~rc5
ubuntu 16.04 linux-kvm any
ubuntu 22.04 linux-lowlatency 5.15.0-48.54
ubuntu upstream linux-lowlatency 5.19~rc5
ubuntu 20.04 linux-lowlatency-hwe-5.15 5.15.0-48.54~20.04.1
ubuntu upstream linux-lowlatency-hwe-5.15 5.19~rc5
ubuntu 14.04 linux-lts-xenial any
ubuntu upstream linux-lts-xenial 5.19~rc5
ubuntu upstream linux-oem 5.19~rc5
ubuntu 20.04 linux-oem-5.10 any
ubuntu upstream linux-oem-5.10 5.19~rc5
ubuntu 20.04 linux-oem-5.13 any
ubuntu upstream linux-oem-5.13 5.19~rc5
ubuntu 20.04 linux-oem-5.14 any
ubuntu upstream linux-oem-5.14 5.19~rc5
ubuntu 22.04 linux-oem-5.17 any
ubuntu upstream linux-oem-5.17 5.19~rc5
ubuntu 20.04 linux-oem-5.6 any
ubuntu upstream linux-oem-5.6 5.19~rc5
ubuntu upstream linux-oem-osp1 5.19~rc5
ubuntu 20.04 linux-oracle any
ubuntu upstream linux-oracle 5.19~rc5
ubuntu 16.04 linux-oracle any
ubuntu upstream linux-oracle-5.0 5.19~rc5
ubuntu 20.04 linux-oracle-5.11 any
ubuntu upstream linux-oracle-5.11 5.19~rc5
ubuntu 20.04 linux-oracle-5.13 any
ubuntu upstream linux-oracle-5.13 5.19~rc5
ubuntu upstream linux-oracle-5.3 5.19~rc5
ubuntu upstream linux-oracle-5.4 5.19~rc5
ubuntu upstream linux-oracle-5.8 5.19~rc5
ubuntu 20.04 linux-raspi any
ubuntu 22.04 linux-raspi 5.15.0-1015.17
ubuntu upstream linux-raspi 5.19~rc5
ubuntu upstream linux-raspi-5.4 5.19~rc5
ubuntu upstream linux-raspi2 5.19~rc5
ubuntu upstream linux-raspi2-5.3 5.19~rc5
ubuntu upstream linux-riscv 5.19~rc5
ubuntu 20.04 linux-riscv-5.11 any
ubuntu upstream linux-riscv-5.11 5.19~rc5
ubuntu upstream linux-riscv-5.8 5.19~rc5
ubuntu upstream linux-snapdragon 5.19~rc5

Related