logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2021-44224

Description

A crafted URI sent to httpd configured as a forward proxy (ProxyRequests on) can cause a crash (NULL pointer dereference) or, for configurations mixing forward and reverse proxy declarations, can allow for requests to be directed to a declared Unix Domain Socket endpoint (Server Side Request Forgery). This issue affects Apache HTTP Server 2.4.7 up to 2.4.51 (included). #### Notes Author| Note ---|--- [mdeslaur](<https://launchpad.net/~mdeslaur>) | fixed by r1895955+r1896044 in 2.4.x


Affected Package


OS OS Version Package Name Package Version
ubuntu 20.04 apache2 2.4.41-4ubuntu3.9
ubuntu 21.04 apache2 2.4.46-4ubuntu1.5
ubuntu 21.10 apache2 2.4.48-3.1ubuntu3.2
ubuntu 22.04 apache2 2.4.52-1ubuntu1
ubuntu 14.04 apache2 2.4.7-1ubuntu4.22+esm3
ubuntu upstream apache2 2.4.52
ubuntu 16.04 apache2 2.4.18-2ubuntu3.17+esm4

Related