logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2021-3246

Description

A heap buffer overflow vulnerability in msadpcm_decode_block of libsndfile 1.0.30 allows attackers to execute arbitrary code via a crafted WAV file.


Affected Package


OS OS Version Package Name Package Version
ubuntu 20.04 libsndfile 1.0.28-7ubuntu0.1
ubuntu 21.04 libsndfile 1.0.31-1ubuntu1.1
ubuntu 21.10 libsndfile 1.0.31-1ubuntu2
ubuntu 22.04 libsndfile 1.0.31-1ubuntu2
ubuntu 14.04 libsndfile 1.0.25-7ubuntu2.2+esm2
ubuntu upstream libsndfile any
ubuntu 16.04 libsndfile 1.0.25-10ubuntu0.16.04.3+esm1

Related