logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2020-36557

Description

A race condition in the Linux kernel before 5.6.2 between the VT_DISALLOCATE ioctl and closing/opening of ttys could lead to a use-after-free.


Affected Package


OS OS Version Package Name Package Version
ubuntu 14.04 linux any
ubuntu upstream linux 5.7~rc1
ubuntu upstream linux-aws 5.7~rc1
ubuntu upstream linux-aws-5.0 5.7~rc1
ubuntu 20.04 linux-aws-5.11 any
ubuntu upstream linux-aws-5.11 5.7~rc1
ubuntu 20.04 linux-aws-5.13 any
ubuntu upstream linux-aws-5.13 5.7~rc1
ubuntu upstream linux-aws-5.15 5.7~rc1
ubuntu upstream linux-aws-5.3 5.7~rc1
ubuntu upstream linux-aws-5.4 5.7~rc1
ubuntu upstream linux-aws-5.8 5.7~rc1
ubuntu upstream linux-aws-hwe 5.7~rc1
ubuntu upstream linux-azure 5.7~rc1
ubuntu upstream linux-azure-4.15 5.7~rc1
ubuntu 20.04 linux-azure-5.11 any
ubuntu upstream linux-azure-5.11 5.7~rc1
ubuntu 20.04 linux-azure-5.13 any
ubuntu upstream linux-azure-5.13 5.7~rc1
ubuntu upstream linux-azure-5.15 5.7~rc1
ubuntu upstream linux-azure-5.3 5.7~rc1
ubuntu upstream linux-azure-5.4 5.7~rc1
ubuntu upstream linux-azure-5.8 5.7~rc1
ubuntu upstream linux-azure-edge 5.7~rc1
ubuntu 20.04 linux-azure-fde any
ubuntu upstream linux-azure-fde 5.7~rc1
ubuntu upstream linux-bluefield 5.7~rc1
ubuntu upstream linux-dell300x 5.7~rc1
ubuntu upstream linux-fips 5.7~rc1
ubuntu upstream linux-gcp 5.7~rc1
ubuntu upstream linux-gcp-4.15 5.7~rc1
ubuntu 20.04 linux-gcp-5.11 any
ubuntu upstream linux-gcp-5.11 5.7~rc1
ubuntu 20.04 linux-gcp-5.13 any
ubuntu upstream linux-gcp-5.13 5.7~rc1
ubuntu upstream linux-gcp-5.15 5.7~rc1
ubuntu upstream linux-gcp-5.3 5.7~rc1
ubuntu upstream linux-gcp-5.4 5.7~rc1
ubuntu upstream linux-gcp-5.8 5.7~rc1
ubuntu upstream linux-gke 5.7~rc1
ubuntu upstream linux-gke-4.15 5.7~rc1
ubuntu upstream linux-gke-5.0 5.7~rc1
ubuntu upstream linux-gke-5.15 5.7~rc1
ubuntu upstream linux-gke-5.3 5.7~rc1
ubuntu upstream linux-gke-5.4 5.7~rc1
ubuntu upstream linux-gkeop 5.7~rc1
ubuntu upstream linux-gkeop-5.4 5.7~rc1
ubuntu upstream linux-hwe 5.7~rc1
ubuntu upstream linux-hwe-5.11 5.7~rc1
ubuntu 20.04 linux-hwe-5.13 any
ubuntu upstream linux-hwe-5.13 5.7~rc1
ubuntu upstream linux-hwe-5.15 5.7~rc1
ubuntu upstream linux-hwe-5.4 5.7~rc1
ubuntu upstream linux-hwe-5.8 5.7~rc1
ubuntu upstream linux-hwe-edge 5.7~rc1
ubuntu upstream linux-ibm 5.7~rc1
ubuntu upstream linux-ibm-5.4 5.7~rc1
ubuntu 20.04 linux-intel-5.13 any
ubuntu upstream linux-intel-5.13 5.7~rc1
ubuntu upstream linux-intel-iotg 5.7~rc1
ubuntu upstream linux-intel-iotg-5.15 5.7~rc1
ubuntu upstream linux-kvm 5.7~rc1
ubuntu upstream linux-lowlatency 5.7~rc1
ubuntu upstream linux-lowlatency-hwe-5.15 5.7~rc1
ubuntu upstream linux-lts-xenial 5.7~rc1
ubuntu upstream linux-oem 5.7~rc1
ubuntu 20.04 linux-oem-5.10 any
ubuntu upstream linux-oem-5.10 5.7~rc1
ubuntu 20.04 linux-oem-5.13 any
ubuntu upstream linux-oem-5.13 5.7~rc1
ubuntu upstream linux-oem-5.14 5.7~rc1
ubuntu upstream linux-oem-5.17 5.7~rc1
ubuntu 20.04 linux-oem-5.6 any
ubuntu upstream linux-oem-5.6 5.7~rc1
ubuntu upstream linux-oem-osp1 5.7~rc1
ubuntu upstream linux-oracle 5.7~rc1
ubuntu upstream linux-oracle-5.0 5.7~rc1
ubuntu 20.04 linux-oracle-5.11 any
ubuntu upstream linux-oracle-5.11 5.7~rc1
ubuntu 20.04 linux-oracle-5.13 any
ubuntu upstream linux-oracle-5.13 5.7~rc1
ubuntu upstream linux-oracle-5.3 5.7~rc1
ubuntu upstream linux-oracle-5.4 5.7~rc1
ubuntu upstream linux-oracle-5.8 5.7~rc1
ubuntu upstream linux-raspi 5.7~rc1
ubuntu upstream linux-raspi-5.4 5.7~rc1
ubuntu upstream linux-raspi2 5.7~rc1
ubuntu upstream linux-raspi2-5.3 5.7~rc1
ubuntu upstream linux-riscv 5.7~rc1
ubuntu 20.04 linux-riscv-5.11 any
ubuntu upstream linux-riscv-5.11 5.7~rc1
ubuntu upstream linux-riscv-5.8 5.7~rc1
ubuntu upstream linux-snapdragon 5.7~rc1

Related