Lucene search

K
ubuntucveUbuntu.comUB:CVE-2020-11089
HistoryMay 29, 2020 - 12:00 a.m.

CVE-2020-11089

2020-05-2900:00:00
ubuntu.com
ubuntu.com
11

6 Medium

CVSS2

Attack Vector

NETWORK

Attack Complexity

MEDIUM

Authentication

SINGLE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:M/Au:S/C:P/I:P/A:P

5.5 Medium

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

LOW

Integrity Impact

LOW

Availability Impact

LOW

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L

0.003 Low

EPSS

Percentile

66.4%

In FreeRDP before 2.1.0, there is an out-of-bound read in irp functions
(parallel_process_irp_create, serial_process_irp_create,
drive_process_irp_write, printer_process_irp_write, rdpei_recv_pdu,
serial_process_irp_write). This has been fixed in 2.1.0.

Notes

Author Note
mdeslaur The freerdp package in Ubuntu 16.04 LTS and Ubuntu 18.04 LTS does not build a server library. This is simply a client denial of service that has a negligible security impact.
OSVersionArchitecturePackageVersionFilename
ubuntu18.04noarchfreerdp< anyUNKNOWN
ubuntu16.04noarchfreerdp< anyUNKNOWN
ubuntu18.04noarchfreerdp2< 2.1.1+dfsg1-0ubuntu0.18.04.1UNKNOWN
ubuntu19.10noarchfreerdp2< 2.1.1+dfsg1-0ubuntu0.19.10.1UNKNOWN
ubuntu20.04noarchfreerdp2< 2.1.1+dfsg1-0ubuntu0.20.04.1UNKNOWN

6 Medium

CVSS2

Attack Vector

NETWORK

Attack Complexity

MEDIUM

Authentication

SINGLE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:M/Au:S/C:P/I:P/A:P

5.5 Medium

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

LOW

Integrity Impact

LOW

Availability Impact

LOW

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L

0.003 Low

EPSS

Percentile

66.4%