Lucene search

K
ubuntucveUbuntu.comUB:CVE-2020-11042
HistoryMay 07, 2020 - 12:00 a.m.

CVE-2020-11042

2020-05-0700:00:00
ubuntu.com
ubuntu.com
10

0.011 Low

EPSS

Percentile

84.7%

In FreeRDP greater than 1.1 and before 2.0.0, there is an out-of-bounds
read in update_read_icon_info. It allows reading a attacker-defined amount
of client memory (32bit unsigned -> 4GB) to an intermediate buffer. This
can be used to crash the client or store information for later retrieval.
This has been patched in 2.0.0.

Bugs

OSVersionArchitecturePackageVersionFilename
ubuntu18.04noarchfreerdp< 1.1.0~git20140921.1.440916e+dfsg1-15ubuntu1.18.04.2UNKNOWN
ubuntu16.04noarchfreerdp< 1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.4UNKNOWN
ubuntu18.04noarchfreerdp2< 2.1.1+dfsg1-0ubuntu0.18.04.1UNKNOWN
ubuntu19.10noarchfreerdp2< 2.1.1+dfsg1-0ubuntu0.19.10.1UNKNOWN
ubuntu20.04noarchfreerdp2< 2.1.1+dfsg1-0ubuntu0.20.04.1UNKNOWN