Lucene search

K
ubuntucveUbuntu.comUB:CVE-2019-9588
HistoryMar 06, 2019 - 12:00 a.m.

CVE-2019-9588

2019-03-0600:00:00
ubuntu.com
ubuntu.com
15

6.8 Medium

CVSS2

Attack Vector

NETWORK

Attack Complexity

MEDIUM

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:M/Au:N/C:P/I:P/A:P

7.8 High

CVSS3

Attack Vector

LOCAL

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

0.001 Low

EPSS

Percentile

44.6%

There is an Invalid memory access in gAtomicIncrement() located at GMutex.h
in Xpdf 4.01. It can be triggered by sending a crafted pdf file to (for
example) the pdftops binary. It allows an attacker to cause Denial of
Service (Segmentation fault) or possibly have unspecified other impact.

Notes

Author Note
jdstrand xpdf in koffice is 2.0
alexmurray according to upstream this and CVE-2019-9587 might be one and the same issue
mdeslaur can’t reproduce with poppler, no indication it is affected as of 2022-01-05, xpdf commit not available.
ebarretto since 0.5.12-1 libextractor does not use xpdf anymore. xpdf in Debian uses poppler, which doesn’t contain the vulnerable code

6.8 Medium

CVSS2

Attack Vector

NETWORK

Attack Complexity

MEDIUM

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:M/Au:N/C:P/I:P/A:P

7.8 High

CVSS3

Attack Vector

LOCAL

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

REQUIRED

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

0.001 Low

EPSS

Percentile

44.6%