logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2019-1010317

Description

WavPack 5.1.0 and earlier is affected by: CWE-457: Use of Uninitialized Variable. The impact is: Unexpected control flow, crashes, and segfaults. The component is: ParseCaffHeaderConfig (caff.c:486). The attack vector is: Maliciously crafted .wav file. The fixed version is: After commit https://github.com/dbry/WavPack/commit/f68a9555b548306c5b1ee45199ccdc4a16a6101b.


Affected Package


OS OS Version Package Name Package Version
ubuntu Upstream wavpack any
ubuntu 18.04 wavpack 5.1.0-2ubuntu1.4

Related