Lucene search

K
ubuntucveUbuntu.comUB:CVE-2018-5126
HistoryMar 14, 2018 - 12:00 a.m.

CVE-2018-5126

2018-03-1400:00:00
ubuntu.com
ubuntu.com
9

7.5 High

CVSS2

Attack Vector

NETWORK

Attack Complexity

LOW

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:L/Au:N/C:P/I:P/A:P

9.8 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

0.006 Low

EPSS

Percentile

78.2%

Memory safety bugs were reported in Firefox 58. Some of these bugs showed
evidence of memory corruption and we presume that with enough effort that
some of these could be exploited to run arbitrary code. This vulnerability
affects Firefox < 59.

Notes

Author Note
tyhicks mozjs contains a copy of the SpiderMonkey JavaScript engine
chrisccoulson This is not fixed in mozjs52, but it’s unclear whether it is unaffected or just ignored as the bugs are still private. Specifically, the following need investigating: - https://bugzilla.mozilla.org/show_bug.cgi?id=1414768 (https://hg.mozilla.org/releases/mozilla-release/rev/8bb6aeb63d5d) - https://bugzilla.mozilla.org/show_bug.cgi?id=1416523 (https://hg.mozilla.org/releases/mozilla-release/rev/5fc563433fcf) - https://bugzilla.mozilla.org/show_bug.cgi?id=1425691 (https://hg.mozilla.org/releases/mozilla-release/rev/cc126cc0f071) - https://bugzilla.mozilla.org/show_bug.cgi?id=1441006 (https://hg.mozilla.org/releases/mozilla-release/rev/1f4e74a5ace8) - https://bugzilla.mozilla.org/show_bug.cgi?id=1422631 (can’t find a changeset referencing it) - https://bugzilla.mozilla.org/show_bug.cgi?id=1426603 (can’t find a changeset referencing it) - https://bugzilla.mozilla.org/show_bug.cgi?id=1373934 (can’t find a changeset referencing it) - https://bugzilla.mozilla.org/show_bug.cgi?id=1423173 (https://hg.mozilla.org/releases/mozilla-release/rev/6a92a108abeb)
OSVersionArchitecturePackageVersionFilename
ubuntu17.10noarchfirefox< 59.0+build5-0ubuntu0.17.10.1UNKNOWN
ubuntu18.04noarchfirefox< 59.0.1+build1-0ubuntu1UNKNOWN
ubuntu18.10noarchfirefox< 59.0.1+build1-0ubuntu1UNKNOWN
ubuntu19.04noarchfirefox< 59.0.1+build1-0ubuntu1UNKNOWN
ubuntu19.10noarchfirefox< 59.0.1+build1-0ubuntu1UNKNOWN
ubuntu20.04noarchfirefox< 59.0.1+build1-0ubuntu1UNKNOWN
ubuntu20.10noarchfirefox< 59.0.1+build1-0ubuntu1UNKNOWN
ubuntu21.04noarchfirefox< 59.0.1+build1-0ubuntu1UNKNOWN
ubuntu21.10noarchfirefox< 59.0.1+build1-0ubuntu1UNKNOWN
ubuntu22.04noarchfirefox< 59.0.1+build1-0ubuntu1UNKNOWN
Rows per page:
1-10 of 191

7.5 High

CVSS2

Attack Vector

NETWORK

Attack Complexity

LOW

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:L/Au:N/C:P/I:P/A:P

9.8 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

0.006 Low

EPSS

Percentile

78.2%