logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2018-16871

Description

A flaw was found in the Linux kernel's NFS implementation, all versions 3.x and all versions 4.x up to 4.20. An attacker, who is able to mount an exported NFS filesystem, is able to trigger a null pointer dereference by using an invalid NFS sequence. This can panic the machine and deny access to the NFS server. Any outstanding disk writes to the NFS server will be lost. #### Bugs * <https://bugzilla.redhat.com/show_bug.cgi?id=1655162>


Affected Package


OS OS Version Package Name Package Version
ubuntu 18.04 linux 4.15.0-46.49
ubuntu 18.10 linux 4.18.0-14.15
ubuntu upstream linux-flo 4.20~rc3
ubuntu 18.04 linux-aws 4.15.0-1033.35
ubuntu 18.10 linux-aws 4.18.0-1008.10
ubuntu 18.10 linux-azure 4.18.0-1008.8
ubuntu 14.04 linux-azure 4.15.0-1040.44~14.04.1)available with ubuntu pro or ubuntu pro (infra-only
ubuntu upstream linux-azure 4.20~rc3
ubuntu 16.04 linux-azure 4.15.0-1040.44
ubuntu 18.04 linux-gcp-edge 4.18.0-1006.7~18.04.1
ubuntu upstream linux-gcp-edge 4.20~rc3
ubuntu 16.04 linux-aws-hwe 4.15.0-1033.35~16.04.1
ubuntu upstream linux-azure-edge 4.20~rc3
ubuntu 16.04 linux-azure-edge 4.15.0-1040.44
ubuntu upstream linux-euclid 4.20~rc3
ubuntu 16.04 linux-euclid any
ubuntu 18.10 linux-gcp 4.18.0-1006.7
ubuntu upstream linux-gcp 4.20~rc3
ubuntu 16.04 linux-gcp 4.15.0-1028.29~16.04.1
ubuntu upstream linux-gke 4.20~rc3
ubuntu upstream linux-gke-4.15 4.20~rc3
ubuntu upstream linux-goldfish 4.20~rc3
ubuntu upstream linux-grouper 4.20~rc3
ubuntu upstream linux-hwe 4.20~rc3
ubuntu 16.04 linux-hwe 4.15.0-46.49~16.04.1
ubuntu upstream linux-hwe-edge 4.20~rc3
ubuntu 16.04 linux-hwe-edge 4.15.0-46.49~16.04.1
ubuntu 18.10 linux-kvm 4.18.0-1007.7
ubuntu upstream linux-kvm 4.20~rc3
ubuntu upstream linux-lts-trusty 4.20~rc3
ubuntu upstream linux-lts-utopic 4.20~rc3
ubuntu upstream linux-lts-vivid 4.20~rc3
ubuntu upstream linux-lts-wily 4.20~rc3
ubuntu upstream linux-lts-xenial 4.20~rc3
ubuntu upstream linux-maguro 4.20~rc3
ubuntu upstream linux-mako 4.20~rc3
ubuntu upstream linux-manta 4.20~rc3
ubuntu 18.10 linux-oem 4.15.0-1034.39
ubuntu upstream linux-oem 4.20~rc3
ubuntu 16.04 linux-oem any
ubuntu 18.10 linux-oracle 4.15.0-1009.11
ubuntu upstream linux-oracle 4.20~rc3
ubuntu 16.04 linux-oracle 4.15.0-1009.11~16.04.1
ubuntu 18.10 linux-raspi2 4.18.0-1009.11
ubuntu upstream linux-raspi2 4.20~rc3
ubuntu upstream linux-snapdragon 4.20~rc3

Related