logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2018-14404

Description

A NULL pointer dereference vulnerability exists in the xpath.c:xmlXPathCompOpEval() function of libxml2 through 2.9.8 when parsing an invalid XPath expression in the XPATH_OP_AND or XPATH_OP_OR case. Applications processing untrusted XSL format inputs with the use of the libxml2 library may be vulnerable to a denial of service attack due to a crash of the application. #### Bugs * <https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=901817> * <https://gitlab.gnome.org/GNOME/libxml2/issues/10> * <https://bugzilla.redhat.com/show_bug.cgi?id=1595985>


Affected Package


OS OS Version Package Name Package Version
ubuntu 18.04 libxml2 2.9.4+dfsg1-6.1ubuntu1.2
ubuntu 12.04 libxml2 2.7.8.dfsg-5.1ubuntu4.21
ubuntu 14.04 libxml2 2.9.1+dfsg1-3ubuntu4.13
ubuntu upstream libxml2 any
ubuntu 16.04 libxml2 2.9.3+dfsg1-1ubuntu0.6

Related