logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2018-1115

Description

postgresql before versions 10.4, 9.6.9 is vulnerable in the adminpack extension, the pg_catalog.pg_logfile_rotate() function doesn't follow the same ACLs than pg_rorate_logfile. If the adminpack is added to a database, an attacker able to connect to it could exploit this to force log rotation. #### Bugs * <https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1115> #### Notes Author| Note ---|--- [mdeslaur](<https://launchpad.net/~mdeslaur>) | 9.6 and 10 only


Affected Package


OS OS Version Package Name Package Version
ubuntu 18.04 postgresql-10 10.4-0ubuntu0.18.04
ubuntu upstream postgresql-10 10.4
ubuntu upstream postgresql-9.6 9.6.9

Related