logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2017-2922

Description

An exploitable memory corruption vulnerability exists in the Websocket protocol implementation of Cesanta Mongoose 6.8. A specially crafted websocket packet can cause a buffer to be allocated while leaving stale pointers which leads to a use-after-free vulnerability which can be exploited to achieve remote code execution. An attacker needs to send a specially crafted websocket packet over the network to trigger this vulnerability. #### Notes Author| Note ---|--- [sbeattie](<https://launchpad.net/~sbeattie>) | mongoose is used on windows only to serve up content for chromecast


Affected Package


OS OS Version Package Name Package Version
ubuntu upstream smplayer any

Related