logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2017-17855

Description

kernel/bpf/verifier.c in the Linux kernel through 4.14.8 allows local users to cause a denial of service (memory corruption) or possibly have unspecified other impact by leveraging improper use of pointers in place of scalars.


Affected Package


OS OS Version Package Name Package Version
ubuntu 12.04 linux any
ubuntu upstream linux 4.15~rc5
ubuntu upstream linux-armadaxp 4.15~rc5
ubuntu upstream linux-aws 4.15~rc5
ubuntu upstream linux-azure 4.15~rc5
ubuntu upstream linux-euclid 4.15~rc5
ubuntu 16.04 linux-euclid any
ubuntu upstream linux-flo 4.15~rc5
ubuntu upstream linux-gcp 4.15~rc5
ubuntu upstream linux-gke 4.15~rc5
ubuntu upstream linux-goldfish 4.15~rc5
ubuntu upstream linux-grouper 4.15~rc5
ubuntu upstream linux-hwe 4.15~rc5
ubuntu upstream linux-hwe-edge 4.15~rc5
ubuntu upstream linux-kvm 4.15~rc5
ubuntu upstream linux-linaro-omap 4.15~rc5
ubuntu upstream linux-linaro-shared 4.15~rc5
ubuntu upstream linux-linaro-vexpress 4.15~rc5
ubuntu upstream linux-lts-quantal 4.15~rc5
ubuntu upstream linux-lts-raring 4.15~rc5
ubuntu upstream linux-lts-saucy 4.15~rc5
ubuntu upstream linux-lts-trusty 4.15~rc5
ubuntu upstream linux-lts-utopic 4.15~rc5
ubuntu 14.04 linux-lts-vivid any
ubuntu upstream linux-lts-vivid 4.15~rc5
ubuntu upstream linux-lts-wily 4.15~rc5
ubuntu upstream linux-lts-xenial 4.15~rc5
ubuntu upstream linux-maguro 4.15~rc5
ubuntu upstream linux-mako 4.15~rc5
ubuntu upstream linux-manta 4.15~rc5
ubuntu upstream linux-oem 4.15~rc5
ubuntu upstream linux-qcm-msm 4.15~rc5
ubuntu upstream linux-raspi2 4.15~rc5
ubuntu upstream linux-snapdragon 4.15~rc5
ubuntu upstream linux-ti-omap4 4.15~rc5

Related