logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2017-13145

Description

In ImageMagick before 6.9.8-8 and 7.x before 7.0.5-9, the ReadJP2Image function in coders/jp2.c does not properly validate the channel geometry, leading to a crash. #### Bugs * <https://github.com/ImageMagick/ImageMagick/issues/501> * <https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=869830> #### Notes Author| Note ---|--- [mdeslaur](<https://launchpad.net/~mdeslaur>) | 0097-Fix-a-crash-in-jp2-codec.patch in unstable 0084-Fix-a-crash-in-jp2-codec.patch in stretch


Affected Package


OS OS Version Package Name Package Version
ubuntu upstream imagemagick 8:6.9.7.4+dfsg-13
ubuntu 16.04 imagemagick 8:6.8.9.9-7ubuntu5.11

Related