CVE-2017-0898

2017-09-15T00:00:00
ID UB:CVE-2017-0898
Type ubuntucve
Reporter ubuntu.com
Modified 2017-09-15T00:00:00

Description

Ruby before 2.4.2, 2.3.5, and 2.2.8 is vulnerable to a malicious format string which contains a precious specifier (*) with a huge minus value. Such situation can lead to a buffer overrun, resulting in a heap memory corruption or an information disclosure from the heap.

Bugs

  • <https://github.com/mruby/mruby/issues/3722>
  • <http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=875936>

Notes

Author| Note
---|---
mdeslaur | backported patch in debian (2.3.3-1+deb9u2) package