logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2016-9064

Description

Add-on updates failed to verify that the add-on ID inside the signed package matched the ID of the add-on being updated. An attacker who could perform a man-in-the-middle attack on the user's connection to the update server and defeat the certificate pinning protection could provide a malicious signed add-on instead of a valid update. This vulnerability affects Firefox ESR < 45.5 and Firefox < 50.


Affected Package


OS OS Version Package Name Package Version
ubuntu 14.04 firefox trusty was released [50.0+build2-0ubuntu0.14.04.2]
ubuntu upstream firefox 50.0
ubuntu 16.04 firefox 50.0+build2-0ubuntu0.16.04.2
ubuntu 16.10 firefox 50.0+build2-0ubuntu0.16.10.2

Related