CVE-2016-5769

2016-06-24T00:00:00
ID UB:CVE-2016-5769
Type ubuntucve
Reporter ubuntu.com
Modified 2016-06-24T00:00:00

Description

Multiple integer overflows in mcrypt.c in the mcrypt extension in PHP before 5.5.37, 5.6.x before 5.6.23, and 7.x before 7.0.8 allow remote attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly have unspecified other impact via a crafted length value, related to the (1) mcrypt_generic and (2) mdecrypt_generic functions.

Bugs

  • <https://bugs.php.net/bug.php?id=72455>

Notes

Author| Note
---|---
seth-arnold | The fix relies upon signed multiplication turning into negative numbers. Since this is undefined in C, the fix doesn't feel complete or or correct to me.