logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2015-9016

Description

In blk_mq_tag_to_rq in blk-mq.c in the upstream kernel, there is a possible use after free due to a race condition when a request has been previously freed by blk_mq_complete_request. This could lead to local escalation of privilege. Product: Android. Versions: Android kernel. Android ID: A-63083046.


Affected Package


OS OS Version Package Name Package Version
ubuntu 12.04 linux any
ubuntu upstream linux 4.3~rc1
ubuntu upstream linux-armadaxp 4.3~rc1
ubuntu upstream linux-aws 4.3~rc1
ubuntu upstream linux-azure 4.3~rc1
ubuntu upstream linux-euclid 4.3~rc1
ubuntu upstream linux-flo 4.3~rc1
ubuntu upstream linux-gcp 4.3~rc1
ubuntu upstream linux-gke 4.3~rc1
ubuntu upstream linux-goldfish 4.3~rc1
ubuntu 16.04 linux-goldfish any
ubuntu upstream linux-grouper 4.3~rc1
ubuntu upstream linux-hwe 4.3~rc1
ubuntu 18.04 linux-hwe-edge 4.18.0-8.9~18.04.1
ubuntu upstream linux-hwe-edge 4.3~rc1
ubuntu upstream linux-kvm 4.3~rc1
ubuntu upstream linux-linaro-omap 4.3~rc1
ubuntu upstream linux-linaro-shared 4.3~rc1
ubuntu upstream linux-linaro-vexpress 4.3~rc1
ubuntu upstream linux-lts-quantal 4.3~rc1
ubuntu upstream linux-lts-raring 4.3~rc1
ubuntu upstream linux-lts-saucy 4.3~rc1
ubuntu 12.04 linux-lts-trusty any
ubuntu upstream linux-lts-trusty 4.3~rc1
ubuntu upstream linux-lts-utopic 4.3~rc1
ubuntu 14.04 linux-lts-vivid any
ubuntu upstream linux-lts-vivid 4.3~rc1
ubuntu upstream linux-lts-wily 4.3~rc1
ubuntu upstream linux-lts-xenial 4.3~rc1
ubuntu upstream linux-maguro 4.3~rc1
ubuntu upstream linux-mako 4.3~rc1
ubuntu upstream linux-manta 4.3~rc1
ubuntu upstream linux-oem 4.3~rc1
ubuntu upstream linux-qcm-msm 4.3~rc1
ubuntu upstream linux-raspi2 4.3~rc1
ubuntu upstream linux-snapdragon 4.3~rc1
ubuntu upstream linux-ti-omap4 4.3~rc1

Related