Lucene search

K
ubuntucveUbuntu.comUB:CVE-2011-3607
HistoryNov 08, 2011 - 12:00 a.m.

CVE-2011-3607

2011-11-0800:00:00
ubuntu.com
ubuntu.com
18

CVSS2

4.4

Attack Vector

LOCAL

Attack Complexity

MEDIUM

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:L/AC:M/Au:N/C:P/I:P/A:P

EPSS

0.001

Percentile

26.5%

Integer overflow in the ap_pregsub function in server/util.c in the Apache
HTTP Server 2.0.x through 2.0.64 and 2.2.x through 2.2.21, when the
mod_setenvif module is enabled, allows local users to gain privileges via a
.htaccess file with a crafted SetEnvIf directive, in conjunction with a
crafted HTTP request header, leading to a heap-based buffer overflow.

Bugs

OSVersionArchitecturePackageVersionFilename
ubuntu8.04noarchapache2< 2.2.8-1ubuntu0.23UNKNOWN
ubuntu10.04noarchapache2< 2.2.14-5ubuntu8.8UNKNOWN
ubuntu10.10noarchapache2< 2.2.16-1ubuntu3.5UNKNOWN
ubuntu11.04noarchapache2< 2.2.17-1ubuntu1.5UNKNOWN
ubuntu11.10noarchapache2< 2.2.20-1ubuntu1.2UNKNOWN

CVSS2

4.4

Attack Vector

LOCAL

Attack Complexity

MEDIUM

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:L/AC:M/Au:N/C:P/I:P/A:P

EPSS

0.001

Percentile

26.5%