logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2009-2942

Description

The mysql-ocaml bindings 1.0.4 for MySQL do not properly support the mysql_real_escape_string function, which might allow remote attackers to leverage escaping issues involving multibyte character encodings.


Affected Package


OS OS Version Package Name Package Version
ubuntu 08.04 mysql-ocaml 1.0.4-4+lenny1build0.8.04.1
ubuntu 08.10 mysql-ocaml 1.0.4-4+lenny1build0.8.10.1
ubuntu 09.04 mysql-ocaml 1.0.4-4+lenny1build0.9.04.1
ubuntu upstream mysql-ocaml 1.0.4-7

Related