logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2009-1959

Description

Off-by-one error in the event_wallops function in fe-common/irc/fe-events.c in irssi 0.8.13 allows remote IRC servers to cause a denial of service (crash) via an empty command, which triggers a one-byte buffer under-read and a one-byte buffer underflow. #### Bugs * [http://bugs.irssi.org/index.php?do=details&task_id=662](<http://bugs.irssi.org/index.php?do=details&task_id=662>)


Affected Package


OS OS Version Package Name Package Version
ubuntu 08.04 irssi 0.8.12-3ubuntu3.1
ubuntu 08.10 irssi 0.8.12-4ubuntu2.1
ubuntu 09.04 irssi 0.8.12-6ubuntu1.1
ubuntu upstream irssi 0.8.13-2

Related