logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2009-1180

Description

The JBIG2 decoder in Xpdf 3.02pl2 and earlier, CUPS 1.3.9 and earlier, Poppler before 0.10.6, and other products allows remote attackers to execute arbitrary code via a crafted PDF file that triggers a free of invalid data. #### Notes Author| Note ---|--- [jdstrand](<https://launchpad.net/~jdstrand>) | CUPS on Ubuntu uses system pdftops (compiled with --disable-pdftops)


Affected Package


OS OS Version Package Name Package Version
ubuntu upstream cups 1.3.10
ubuntu upstream cupsys 1.3.10
ubuntu upstream gpdf any
ubuntu 07.10 ipe any
ubuntu 08.10 ipe any
ubuntu upstream ipe any
ubuntu upstream kdegraphics any
ubuntu 07.10 koffice any
ubuntu 08.10 koffice any
ubuntu 09.04 koffice 1:1.6.3-7ubuntu6.1
ubuntu upstream koffice any
ubuntu 18.04 libextractor any
ubuntu 20.04 libextractor any
ubuntu 07.10 libextractor any
ubuntu 08.10 libextractor any
ubuntu 22.04 libextractor any
ubuntu upstream libextractor any
ubuntu 12.04 libextractor any
ubuntu 14.04 libextractor any
ubuntu upstream libextractor any
ubuntu 16.04 libextractor any
ubuntu upstream pdfkit.framework any
ubuntu upstream pdftohtml any
ubuntu 18.04 poppler 0.10.5-1ubuntu2
ubuntu 18.10 poppler 0.10.5-1ubuntu2
ubuntu 06.06 poppler 0.5.1-0ubuntu7.5
ubuntu 19.04 poppler 0.10.5-1ubuntu2
ubuntu 19.10 poppler 0.10.5-1ubuntu2
ubuntu 20.04 poppler 0.10.5-1ubuntu2
ubuntu 20.10 poppler 0.10.5-1ubuntu2
ubuntu 07.10 poppler any
ubuntu 08.04 poppler 0.6.4-1ubuntu3.2
ubuntu 21.04 poppler 0.10.5-1ubuntu2
ubuntu 21.10 poppler 0.10.5-1ubuntu2
ubuntu 08.10 poppler 0.8.7-1ubuntu0.2
ubuntu 22.04 poppler 0.10.5-1ubuntu2
ubuntu 09.04 poppler 0.10.5-1ubuntu2
ubuntu 09.10 poppler 0.10.5-1ubuntu2
ubuntu upstream poppler 0.10.5-1ubuntu2
ubuntu 10.04 poppler 0.10.5-1ubuntu2
ubuntu 10.10 poppler 0.10.5-1ubuntu2
ubuntu 11.04 poppler 0.10.5-1ubuntu2
ubuntu 11.10 poppler 0.10.5-1ubuntu2
ubuntu 12.04 poppler precise was released [0.10.5-1ubuntu2]
ubuntu 12.10 poppler 0.10.5-1ubuntu2
ubuntu 13.04 poppler 0.10.5-1ubuntu2
ubuntu 13.10 poppler 0.10.5-1ubuntu2
ubuntu 14.04 poppler trusty was released [0.10.5-1ubuntu2]
ubuntu upstream poppler any
ubuntu 14.10 poppler 0.10.5-1ubuntu2
ubuntu 15.04 poppler 0.10.5-1ubuntu2
ubuntu 15.10 poppler 0.10.5-1ubuntu2
ubuntu 16.04 poppler 0.10.5-1ubuntu2
ubuntu 16.10 poppler 0.10.5-1ubuntu2
ubuntu 17.04 poppler 0.10.5-1ubuntu2
ubuntu upstream tetex-bin any
ubuntu upstream texlive-bin any
ubuntu 07.10 xpdf any
ubuntu 08.10 xpdf any
ubuntu 09.04 xpdf 3.02-1.4ubuntu2.9.04.1
ubuntu 09.10 xpdf 3.02-1.4ubuntu2.9.10.1
ubuntu upstream xpdf 3.02-2

Related