Lucene search

K
ubuntucveUbuntu.comUB:CVE-2007-2452
HistoryJun 04, 2007 - 12:00 a.m.

CVE-2007-2452

2007-06-0400:00:00
ubuntu.com
ubuntu.com
6

CVSS2

7.2

Attack Vector

LOCAL

Attack Complexity

LOW

Authentication

NONE

Confidentiality Impact

COMPLETE

Integrity Impact

COMPLETE

Availability Impact

COMPLETE

AV:L/AC:L/Au:N/C:C/I:C/A:C

EPSS

0.007

Percentile

79.5%

Heap-based buffer overflow in the visit_old_format function in
locate/locate.c in locate in GNU findutils before 4.2.31 might allow
context-dependent attackers to execute arbitrary code via a long pathname
in a locate database that has the old format, a different vulnerability
than CVE-2001-1036.

Notes

Author Note
kees slocate runs instead of the findutils, and this would require an root-user-owned-db attack or similar.

CVSS2

7.2

Attack Vector

LOCAL

Attack Complexity

LOW

Authentication

NONE

Confidentiality Impact

COMPLETE

Integrity Impact

COMPLETE

Availability Impact

COMPLETE

AV:L/AC:L/Au:N/C:C/I:C/A:C

EPSS

0.007

Percentile

79.5%