Lucene search

K
ubuntuUbuntuUSN-5840-1
HistoryFeb 02, 2023 - 12:00 a.m.

Long Range ZIP vulnerabilities

2023-02-0200:00:00
ubuntu.com
33

9.8 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

6.3 Medium

AI Score

Confidence

High

7.5 High

CVSS2

Access Vector

Access Complexity

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:L/Au:N/C:P/I:P/A:P

0.002 Low

EPSS

Percentile

54.8%

Releases

  • Ubuntu 22.10
  • Ubuntu 22.04 LTS
  • Ubuntu 20.04 LTS
  • Ubuntu 18.04 ESM
  • Ubuntu 16.04 ESM
  • Ubuntu 14.04 ESM

Packages

  • lrzip - compression program with a very high compression ratio

Details

It was discovered that Long Range ZIP incorrectly handled pointers. If
a user or an automated system were tricked into opening a certain
specially crafted ZIP file, an attacker could possibly use this issue
to cause a denial of service. This issue only affected Ubuntu 14.04 ESM,
Ubuntu 16.04 ESM, Ubuntu 18.04 LTS, and Ubuntu 20.04 LTS. (CVE-2020-25467)

It was discovered that Long Range ZIP incorrectly handled pointers. If
a user or an automated system were tricked into opening a certain
specially crafted ZIP file, an attacker could possibly use this issue
to cause a denial of service. This issue only affected Ubuntu 18.04 LTS
and Ubuntu 20.04 LTS. (CVE-2021-27345, CVE-2021-27347)

It was discovered that Long Range ZIP incorrectly handled pointers. If
a user or an automated system were tricked into opening a certain
specially crafted ZIP file, an attacker could possibly use this issue
to cause a denial of service. This issue only affected Ubuntu 16.04 ESM,
Ubuntu 18.04 LTS, and Ubuntu 20.04 LTS. (CVE-2022-26291)

It was discovered that Long Range ZIP incorrectly handled memory allocation,
which could lead to a heap memory corruption. An attacker could possibly use
this issue to cause denial of service. This issue affected Ubuntu 14.04 ESM,
Ubuntu 16.04 ESM, Ubuntu 18.04 LTS, Ubuntu 20.04 LTS, Ubuntu 22.04 LTS, and
Ubuntu 22.10. (CVE-2022-28044)

OSVersionArchitecturePackageVersionFilename
Ubuntu22.10noarchlrzip< 0.651-2ubuntu0.22.10.1UNKNOWN
Ubuntu22.10noarchlrzip-dbgsym< 0.651-2ubuntu0.22.10.1UNKNOWN
Ubuntu22.04noarchlrzip< 0.651-2ubuntu0.22.04.1UNKNOWN
Ubuntu22.04noarchlrzip-dbgsym< 0.651-2ubuntu0.22.04.1UNKNOWN
Ubuntu20.04noarchlrzip< 0.631+git180528-1+deb10u1build0.20.04.1UNKNOWN
Ubuntu20.04noarchlrzip-dbgsym< 0.631+git180528-1+deb10u1build0.20.04.1UNKNOWN
Ubuntu18.04noarchlrzip< 0.631-1+deb9u3build0.18.04.1UNKNOWN
Ubuntu18.04noarchlrzip-dbgsym< 0.631-1+deb9u3build0.18.04.1UNKNOWN
Ubuntu16.04noarchlrzip< 0.621-1ubuntu0.1~esm2UNKNOWN
Ubuntu16.04noarchlrzip< 0.621-1UNKNOWN
Rows per page:
1-10 of 131

9.8 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

6.3 Medium

AI Score

Confidence

High

7.5 High

CVSS2

Access Vector

Access Complexity

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:L/Au:N/C:P/I:P/A:P

0.002 Low

EPSS

Percentile

54.8%