logo
DATABASE RESOURCES PRICING ABOUT US

OpenSLP vulnerability

Description

It was discovered that OpenSLP did not properly validate URLs. A remote attacker could use this issue to cause OpenSLP to crash or possibly execute arbitrary code.


Affected Package


OS OS Version Package Name Package Version
Ubuntu 16.04 libslp1 1.2.1-11ubuntu0.16.04.2
Ubuntu 16.04 libslp-dev 1.2.1-11ubuntu0.16.04.2
Ubuntu 16.04 libslp1-dbgsym 1.2.1-11ubuntu0.16.04.2
Ubuntu 16.04 openslp-doc 1.2.1-11ubuntu0.16.04.2
Ubuntu 16.04 slpd 1.2.1-11ubuntu0.16.04.2
Ubuntu 16.04 slpd-dbgsym 1.2.1-11ubuntu0.16.04.2
Ubuntu 16.04 slptool 1.2.1-11ubuntu0.16.04.2
Ubuntu 16.04 slptool-dbgsym 1.2.1-11ubuntu0.16.04.2
Ubuntu 14.04 libslp1 1.2.1-9ubuntu0.3+esm1 Available with UA Infra or UA Desktop
Ubuntu 14.04 libslp-dev 1.2.1-9ubuntu0.3+esm1
Ubuntu 14.04 libslp1 1.2.1-9ubuntu0.3+esm1
Ubuntu 14.04 openslp-doc 1.2.1-9ubuntu0.3+esm1
Ubuntu 14.04 slpd 1.2.1-9ubuntu0.3+esm1
Ubuntu 14.04 slptool 1.2.1-9ubuntu0.3+esm1

Related