logo
DATABASE RESOURCES PRICING ABOUT US

wpa_supplicant and hostapd vulnerabilities

Description

USN-4734-1 fixed several vulnerabilities in wpa_supplicant. This update provides the corresponding update for Ubuntu 14.04 ESM. It was discovered that wpa_supplicant did not properly handle P2P (Wi-Fi Direct) group information in some situations, leading to a heap overflow. A physically proximate attacker could use this to cause a denial of service or possibly execute arbitrary code. (CVE-2021-0326) It was discovered that hostapd did not properly handle UPnP subscribe messages in some circumstances. An attacker could use this to cause a denial of service. (CVE-2020-12695)


Affected Package


OS OS Version Package Name Package Version
Ubuntu 14.04 hostapd 1:2.1-0ubuntu1.7+esm3
Ubuntu 14.04 hostapd-dbgsym 1:2.1-0ubuntu1.7+esm3
Ubuntu 14.04 wpagui 1:2.1-0ubuntu1.7+esm3
Ubuntu 14.04 wpagui-dbgsym 1:2.1-0ubuntu1.7+esm3
Ubuntu 14.04 wpasupplicant 1:2.1-0ubuntu1.7+esm3
Ubuntu 14.04 wpasupplicant-dbgsym 1:2.1-0ubuntu1.7+esm3
Ubuntu 14.04 wpasupplicant-udeb 1:2.1-0ubuntu1.7+esm3
Ubuntu 14.04 wpasupplicant-udeb-dbgsym 1:2.1-0ubuntu1.7+esm3
Ubuntu 14.04 wpasupplicant 2.1-0ubuntu1.7+esm3
Ubuntu 14.04 hostapd 2.1-0ubuntu1.7+esm3
Ubuntu 14.04 hostapd-dbgsym 2.1-0ubuntu1.7+esm3
Ubuntu 14.04 wpagui 2.1-0ubuntu1.7+esm3
Ubuntu 14.04 wpagui-dbgsym 2.1-0ubuntu1.7+esm3
Ubuntu 14.04 wpasupplicant-dbgsym 2.1-0ubuntu1.7+esm3
Ubuntu 14.04 wpasupplicant-udeb 2.1-0ubuntu1.7+esm3
Ubuntu 14.04 wpasupplicant-udeb-dbgsym 2.1-0ubuntu1.7+esm3

Related