logo
DATABASE RESOURCES PRICING ABOUT US

libsndfile vulnerabilities

Description

It was discovered that libsndfile incorrectly handled certain malformed files. A remote attacker could use this issue to cause libsndfile to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2017-12562) It was discovered that libsndfile incorrectly handled certain malformed files. A remote attacker could use this issue to cause libsndfile to crash, resulting in a denial of service, or possibly execute arbitrary code. This issue only affected Ubuntu 14.04 ESM. (CVE-2017-14245, CVE-2017-14246, CVE-2017-14634, CVE-2017-16942, CVE-2017-6892, CVE-2018-13139, CVE-2018-19432, CVE-2018-19661, CVE-2018-19662, CVE-2018-19758, CVE-2019-3832)


Affected Package


OS OS Version Package Name Package Version
Ubuntu 16.04 libsndfile1 1.0.25-10ubuntu0.16.04.3
Ubuntu 16.04 libsndfile1-dbg 1.0.25-10ubuntu0.16.04.3
Ubuntu 16.04 libsndfile1-dbgsym 1.0.25-10ubuntu0.16.04.3
Ubuntu 16.04 libsndfile1-dev 1.0.25-10ubuntu0.16.04.3
Ubuntu 16.04 sndfile-programs 1.0.25-10ubuntu0.16.04.3
Ubuntu 16.04 sndfile-programs-dbg 1.0.25-10ubuntu0.16.04.3
Ubuntu 16.04 sndfile-programs-dbgsym 1.0.25-10ubuntu0.16.04.3
Ubuntu 14.04 libsndfile1 1.0.25-7ubuntu2.2+esm1 Available with UA Infra or UA Desktop
Ubuntu 14.04 libsndfile1 1.0.25-7ubuntu2.2+esm1
Ubuntu 14.04 libsndfile1-dbg 1.0.25-7ubuntu2.2+esm1
Ubuntu 14.04 libsndfile1-dbgsym 1.0.25-7ubuntu2.2+esm1
Ubuntu 14.04 libsndfile1-dev 1.0.25-7ubuntu2.2+esm1
Ubuntu 14.04 sndfile-programs 1.0.25-7ubuntu2.2+esm1
Ubuntu 14.04 sndfile-programs-dbg 1.0.25-7ubuntu2.2+esm1
Ubuntu 14.04 sndfile-programs-dbgsym 1.0.25-7ubuntu2.2+esm1
Ubuntu 14.04 sndfile-programs 1.0.25-7ubuntu2.2+esm1 Available with UA Infra or UA Desktop

Related