logo
DATABASE RESOURCES PRICING ABOUT US

Oniguruma vulnerabilities

Description

It was discovered that Oniguruma incorrectly handled certain regular expressions. An attacker could possibly use this issue to cause a denial of service, obtain sensitive information or other unspecified impact. (CVE-2019-16163, CVE-2019-19012, CVE-2019-19204, CVE-2019-19246)


Affected Package


OS OS Version Package Name Package Version
Ubuntu 14.04 libonig2 5.9.1-1ubuntu1.1+esm2
Ubuntu 14.04 libonig-dev 5.9.1-1ubuntu1.1+esm2
Ubuntu 14.04 libonig-dev-dbgsym 5.9.1-1ubuntu1.1+esm2
Ubuntu 14.04 libonig2-dbg 5.9.1-1ubuntu1.1+esm2
Ubuntu 14.04 libonig2-dbgsym 5.9.1-1ubuntu1.1+esm2

Related