logo
DATABASE RESOURCES PRICING ABOUT US

NTFS-3G vulnerability

Description

A heap buffer overflow was discovered in NTFS-3G when executing it with a relative mount point path that is too long. A local attacker could potentially exploit this to execute arbitrary code as the administrator.


Affected Package


OS OS Version Package Name Package Version
Ubuntu 18.10 ntfs-3g 1:2017.3.23-2ubuntu0.18.10.1
Ubuntu 18.04 ntfs-3g 1:2017.3.23-2ubuntu0.18.04.1
Ubuntu 18.04 libntfs-3g88 1:2017.3.23-2ubuntu0.18.04.1
Ubuntu 18.04 ntfs-3g-dbg 1:2017.3.23-2ubuntu0.18.04.1
Ubuntu 18.04 ntfs-3g-dev 1:2017.3.23-2ubuntu0.18.04.1
Ubuntu 18.04 ntfs-3g-udeb 1:2017.3.23-2ubuntu0.18.04.1
Ubuntu 16.04 ntfs-3g 1:2015.3.14AR.1-1ubuntu0.2
Ubuntu 16.04 ntfs-3g-dbg 1:2015.3.14AR.1-1ubuntu0.2
Ubuntu 16.04 ntfs-3g-dbgsym 1:2015.3.14AR.1-1ubuntu0.2
Ubuntu 16.04 ntfs-3g-dev 1:2015.3.14AR.1-1ubuntu0.2
Ubuntu 16.04 ntfs-3g-dev-dbgsym 1:2015.3.14AR.1-1ubuntu0.2
Ubuntu 16.04 ntfs-3g-udeb 1:2015.3.14AR.1-1ubuntu0.2
Ubuntu 16.04 ntfs-3g-udeb-dbgsym 1:2015.3.14AR.1-1ubuntu0.2

Related